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The Index contains a list of all Help topics available for Chaos. For information on how
to use Help, press F1 or choose Using Help from the Help menu.

In addition, you can press Shift-F1 and then click on a menu item to get help for that menu 
item.



Draw/Pause/Resume Button

A mouse click on the Draw button starts drawing the current fractal image. 

While drawing is in progress, the button changes to the Pause button.    Click this to suspend
calculation without losing your place.    While drawing is paused, the button is titled 
Resume.    Click Resume to continue drawing where you paused.



Choose Button

The Choose button brings up a dialog box that lets you to choose which type of fractal 
image to generate.    In this application, there are three possibilities:    the Mandelbrot set, 
Julia sets, and fractal dragons.



Parameters Button

The Parameters button brings up a dialog box that lets you select values that are used to 
compute and display the type of fractal image you have chosen.

There are two types of values you can set in this dialog:

Computation options:

These four values determine what the set will look like.

Zreal: This is the real part of the seed value.
Zimaginary: This is the imaginary part of the seed value.
Maximum distance: The function stops iterating as soon as the value of the function 

reaches or exceeds this value.
Number of iterations:If the value of the function never reaches Maximum Distance, 

the function will stop iterating after this many iterations have 
been completed.

Display options:

The first four options control the position and size of the viewport.

X: The X value of the center of the viewport
Y: The Y value of the center of the viewport
Width: The width of the viewport
Height: The height of the viewport

Color Scale: Tells the program how many entries to skip in the palette.    A value of 
one means that no entries are skipped, and produces very smooth 
shading.    A value of 10 skips 9 palette entries, and produces high 
contrast images.



Color Scale 2

Color Scale: 6



Pixel Size Button

This button allows you to choose the size of the pixels the fractal generator uses.    This has a
large effect on how fast you want the fractal image computes.    The larger the pixels, the 
faster the computation time, but the less accurate it displays.    Since these logical pixels are 
always square, you cannot set the aspect ratio, just the dimensions.

The four choices are:
Smallest Pixels - This sets the logical pixel size to the smallest possible (1 X 1, so one 

logical pixel equals one screen pixel).    This will create the best looking 
image, but will take the longest.

Smaller Pixels - This reduces the current logical pixel size by half.    This helps to get a 
better idea of what the area in your viewport looks like, but will take 
about 4 times longer to paint the whole screen. 

Bigger Pixels - This increases the logical pixel size by a factor of 2.    You will get much
faster painting, but the image will look all blocky.

Biggest Pixels - This just gives you a rough estimate of what the area in the viewport 
will look like.    However, the painting is very fast.

Of course, there is a trade-off.    You want it to be very accurate, and display very quickly.    
Unfortunately, you can have one or the other:    high accuracy means slower painting, and 
vice versa.

To get greater accuracy you want small pixels.    This means that there are more of them that
the computer has to calculate, and more calculation takes more time.

To get faster painting, you want larger pixels.    That means that there are less of them that 
the computer has to calculate, and fewer calculations take less time.



Zoom Out Button

This button allows you to back off from the region you are currently painting.    It increases 
the viewport size by 25%.
 



Edit Palette Button

Use the right mouse button (or arrow keys when the palette control has the focus) to place 
the current palette indicator box (the rectangle that outlines the palette entry).

Once on the entry you want to edit, you can use the scroll bars to adjust the Red, Green, and
Blue values.

Use the left and right mouse buttons to place the little triangles on either end of the range 
you want to shade.    Pressing the shade button will produce an even shading of the palette 
entries between the little triangles.

If you want to draw a grey scale mandelbrot, change the palette from Color to Grey Scale by 
pressing the Grey Scale Button.    After changing the Color Options, you will have to 
recalculate the fractal set with the new values.



Shift

Shifts the viewport over by the size of the viewport.    Useful for making tiled images for 
printing.



File Menu

The File menu includes commands that enable you to establish a new workspace and to exit 
the application.    In this version, the application does not load or save files.

For more information on a command, select the File menu command name below:

New Clears the screen in preparation for drawing a new image.
Save Saves the current image to a file.
Exit Exits the application



File New Command

Clears the screen of the current image.

For this command, from the main menu, choose File, and then New.

The keyboard accelerator for this command is Shift-Delete.



File Save Command

Writes the current bitmap to a file.    Available formats:

Windows device independent bitmap (DIB)
Windows device dependent bitmap (DDB)
Windows 8 bit compressed run length encoded (RLE)
Presentation Manager bitmap format



File Exit Command

Exits the Chaos application.

To exit, you may also :
Choose Close off the system menu
Double click on the system menu

For this command, rom the main menu, choose File, and then Exit.

The keyboard accelerator for this command is Alt-F4.



Edit Menu

The Edit menu includes commands that enable you to edit the current palette and copy 
images to and from the clipboard.

For more information, select the Edit menu command name below:

Copy Copies the current image to the clipboard.    If there is no current image, this option is
greyed out.
Paste Bitmap Gets the current bitmap from the clipboard.    If there are more than one 
bitmap format on the clipboard, it will choose the DIB format before DDB    If there is no 
object of type bitmap on the clipboard, this option is greyed out.
Paste Palette Gets the palette from the clipboard and uses it to draw the current fractal 
type.    If there is no palette on the clipboard, this option is greyed out.



Edit Copy Command

To copy an image from the active window to the clipboard, choose COPY off of the EDIT 
menu.

This operation will put the current image onto the clipboard in two formats:
Device Dependent Bitmap Format (DDB) (with an accompanying palette if you are in 

256 color mode).
Device Independent Bitmap Format (DIB)

The keyboard accelerator for this command is Ctrl-Insert.



Edit Paste Bitmap Command

To paste an image from the clipboard to the current window, select PASTE from the edit 
menu.

The keyboard accelerator for this command is Shift-Insert.



Edit Paste Palette Command

To paste an image from the clipboard to the current window, select PASTE from the edit 
menu.

The keyboard accelerator for this command is Shift-Insert.



Options Menu

For more information, select the Options menu command name:

Step Toggles whether the Chaos program will stop after completion of each 
screen.

Ribbon Bar Toggles whether the ribbon bar is visible.
Status Window Toggles whether the status window is visible at the bottom of the 

screen.
View Palette Brings up a dialog box that displays the current palette.



Options Step

This option controls whether the program keeps painting the screen with successively 
smaller pixels, or just completes one screen with the current pixel size.    When step mode is 
ON, a check mark appears next to the Step item on the menu.    
When step mode is ON, you must click the Draw button to restart drawing after each screen 

finishes painting.

When step mode is OFF, painting will continue until the program reaches the maximum 
resolution of your hardware.



Options Ribbon Bar

Toggles whether the ribbon bar is visible.    The ribbon bar is a floating window with buttons 
that execute application features.



Options Status Window
Toggles whether the status window is visible at the bottom of the screen.    The status 
window is where menu help is displayed, and the status of the current fractal computation.

If you turn the status window off, you get slightly more screen area to view the fractal.    
Having the status window visible does not affect how much of the image is pasted to the 
clipboard.



Options View Palette
This menu item brings up a dialog box that displays the current palette.    This is only used to
view the palette.    To change the palette, you must choose Palette off the Edit menu.



Creating Fractal Images

When you start up Chaos, it will have a pre-calculated image of the Mandelbrot set on the 
screen.    At this point you can choose another type of fractal (with the Choose button) or 
use the mouse to drag a box around an area you are interested in.

Once you have dragged a box around the area you are interested in, drawing will 
commence.    If you have the step mode turned off, Chaos will draw a rough approximation of
the area of the fractal image you have selected, and then repeat.    Each successive drawing 
will have higher and higher resolution, until it reaches the maximum resolution of your 
hardware.

If you want the software to wait for you to tell it to draw after each pass, turn step mode on.

If you want to draw in the highest resolution without waiting, click on the Pixel Size button 
and choose "smallest".



Using the mouse to navigate an image

Once you have a fractal image on the screen, you can "drive around" using the mouse.
To do this:

- Drag a box around the area you want to explore.
- When you release the mouse button, the area you selected will be stretched to fill 
the screen, and the fractal computation will begin again, using the parameters of the 
new location.

You can do this as many times as you want.    The beauty of fractals is that you never run out
of things to explore - you will finally bottom out when your computer starts rounding off 
digits.



Copying Images

To copy an image to the clipboard, choose Copy off of the Edit menu.    This will place a copy 
of the image in device dependent format.

In 256 color mode, it will also place an accompanying palette that describes all the colors 
used in the image.



Clearing an image

To erase the current image, choose New from the File menu.    This will clear the screen, and 
reset the state of the program to when you started.



Exiting

To exit Chaos, choose Exit from the File menu, or from the system menu.



Registration

Why to register:

Registration gets you the latest version of the software, it puts you on the mailing list 
to be notified of future updates, and it gives me the incentive to fix bugs and write more 
code, because I know someone is using the software.

What you get:
- If I have fixed a lot of bugs or added new features, I will create a new release of the 
software.    If there is one newer than the one you have, I will send you a copy of the 
newest release of the software.    Includes:

Bugfixes
New Features
Improvements (easier to use, faster computation)



How to register:
Send $15 (check or money order) to Chuck Lindgren.

Mailing address:

Chuck Lindgren
5 Suffolk Drive
Littleton, MA 01460

To register, use the form on the following page (hit the [Browse >>] button above, then print
the form to by selecting Print from the File menu).



Invoice

Remit To:

Chuck Lindgren
5 Suffolk Drive
Littleton, MA 01460

From:

Number of copies: ____        @ $15 each = $ _____

I use 5 1/4"/3 1/2" disks (circle one)

They are low/high density (circle one)

I got Chaos from a bulletin board/shareware distributor (circle one)

Name of bulletin board/shareware distributor: _______________

I currently have version 3.1 of Chaos.    Please send me a newer 
version if one exists.

(If a newer version than 3.1 exists, upon receipt of this paid invoice,
your diskette will be sent out.)

Comments (likes, dislikes, suggestions, new feature requests):



Hardware Configuration

This software was developed and tested on a Dell 486/33 with a color monitor, a VGA 
graphics card, and a mouse.    The graphics card is one of the Video 7 types for which 
Windows supplies a 256 color driver.

Speed of computation:
The single thing that will make the biggest difference is a floating point coprocessor.    
Without one, if you have a substantially slower machine, fractal computation can take a long
time (depending on the resolution you select, and the number of iterations you are 
computing).    Even with a fast machine, some high resolution full-screen fractal images can 
easily take hours to compute.    However, there are a couple of things you can do to make it 
easy on yourself.

Pixel size:    That's easy -    the bigger the pixels, the fewer there are to calculate.

Number of iterations:    When you hit the Parameters button, a dialog box comes 
up that asks you for a bunch of parameters.    One of these is "number of iterations" 
(default is 256 for Mandelbrot).    If you make this a smaller number, the resulting 
image is sometimes less complex, but may compute much faster.

Amount of area in "the set":    The area that shows up as black in an image is 
described as actually being part of the Mandelbrot set.    It is defined as all points for 
which the maximum number of iterations is reached without exceeding the threshold 
value.    Basically, the black part is the most expensive, computation-wise.    If you 
choose an image to compute without much black part, it will compute much faster 
than one with a lot of pixels in the Mandelbrot set.

Finally, if you must compute a monster fractal image, do it overnight or in the 
background (while you are doing something else with another application in Windows).    
Warning:    computing fractals in the background will use up CPU time, and slow down 
whatever you are doing in the foreground!

Image Quality:
If you do not already have one, I strongly urge you to go out and get a video board that has 
a driver that will display 256 colors in Windows.    They are not that expensive (there are 
several for under $200), and the difference it makes when you are using color intensive 
graphics applications is phenominal.
 



New Features

New features in this release:
- "Default" button on edit palette dialog
- DLL interface
- removed Paste support
- 8087 Math coprocessor support (auto-detect and load)
- ribbon buttons on a toolbox
- File I/O - now you can save to Windows and OS/2 bitmaps
- Improved system response time during calculation (more frequent yeilds)

Bugs Fixed:
- text in status line sometimes paints with wrong font
- % done figure displays wrong number after 900 lines (on high res display)
- text in "send money" screen is off on high res displays
- correct fractal icons on "choose" dialog

I am always thinking of new features or improvements to existing features.    To receive 
updates containing new features, improvements, and bugfixes, send in your registration fee. 
In addition, registered users are welcome to make suggestions for new features.



Coming Attractions

Here are a few of the things that may appear in future releases:

- Improved status window, telling the fractal type and parameters
- Palette animator
- Iterated Function Systems
- Speeding up fractal calculation and screen painting
- Printing
- Optimal calculation for images straddling the x-axis
- Excel style 3-D status bar
- When minimized, icon title is percent done (like WinGif)
- CreateDialog instead of DialogBox for view palette
- Keyboard interface for ribbon buttons (accelerators, tab, sh-tab)
- copy DIB to clipboard
- default palette goes from blue to gold
- draw pkg in a DLL to take advantage of 387 when present
- shift-F1 help for ribbon buttons



Known Bugs

I am continually working on this application, and periodically cut a release when I feel that I 
have accumulated enough new features and bugfixes to make it worth while.    Inevitably, 
there are some bugs that I either didn't know about, can't find, or don't bother to fix.

This list is intended to give you and idea of what to expect, and of what I hope to fix in the 
next release.

This help system is not yet finished.
Need "default" button on edit palette dialog
Status bar paints text in a big bold font the first time

If you find a bug not on this list, send it in with your registration, and I will try to make sure 
it gets fixed in the next release.



Glossary

ClipboardDDBDIB
Fractal DragonFatou, Pierre
FractalJulia, GastonJulia SetMandelbrot, BenoitMandelbrot SetViewport



Clipboard

The Windows clipboard enables you to share data between applications.    If you copy an 
image to the clipboard, you can then paste it into any Windows application that contains 
clipboard support.

Example:

Problem:
You want to save the bitmap in your current window in TIFF format.

Solution:
Copy the image to the clipboard.    Paste it into an application that supports the TIFF 

file format.    Save the image from that application.



 Mandelbrot Set

All points c associated with connected Julia sets.



 Viewport

A viewport is a window that you use to view the fractal patterns.    You can change the size 
and position of a viewport by dragging an area with the mouse, using the Parameters 
button, or the Zoom Out button.



 Julia Set

The Julia set is composed of fractal boundaries that emerge from the iteration of the 
quadratic transformation z2+c.    They take on a bewildering variety of shapes that depend 
only on the number c, called a control parameter.    Some values of c lead to Julia sets that 
are in one piece.    Other values yeild Julia sets that are disconnected and dust-like.



 Dragons

A kind of fractal image, so named because of their visual similarity to the classical dragon 
shape (like the traditional Chinese tapestry representations).



 Fractal

A term coined by Benoit Mandelbrot to describe all curves whose Hausdorff-Besicovitch 
dimension is greater than their Euclidian dimension.

From the Latin fractus, the adjectival form of frangere, or "to break".



 DIB

The Device Independent Bitmap format was introduced by Microsoft in Windows 3.0.    It 
consists of a bitmap header containing information about the bitmap (like the dimensions 
and number of colors) followed by a color table (containing either RGB values or indices into 
a palette) followed by the bits of the image.

The advantage to this format is that a bitmap created on one system can be transferred to 
another system with different dispay capabilities.    When the second device tries to render 
the bitmap, it can use the information stored in the bitmap to make intelligent decisions 
about how best to convert the display format.



 DDB

Bitmap that relies on the specific characteristics of a device for proper display (resolution, 
number of colors, pixel aspect ratio).



 Benoit Mandelbrot

A mathemetician at the IBM Thomas J. Watson Research Center in Yorktown Heights, N.Y., 
Mandelbrot is best known for coining the term "fractal" in 1975 to describe certain 
phenomena (such as coastlines, snowflakes, and mountains) whose patterns repeat 
themselves at smaller and smaller scales.

Though generally accepted as the discoverer of the set with it's unique fractal properties, 
some controversy exists.    An interesting discussion of the set's origin can be found in the 
April 1990 issue of Scientific American, on page 30.



 Gaston Julia

Successfully claimed that the work he did was more significant than Fatou's.    Taught 
Mandelbrot in the late 1940's. 



 Pierre Fatou

An early researcher in the field of iterative functions, Fatou described some of the set's 
peculiar properties as early as 1906.
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To do:

Optimal calculation for images straddling the x-axis
Excel style 3-D status bar
When minimized, icon title is percent done (like WinGif)
CreateDialog instead of DialogBox for view palette
Keyboard interface for ribbon buttons (accelerators, tab, sh-tab)
default palette goes from blue to gold
draw pkg in a DLL to take advantage of 387 when present
shift-F1 help for ribbon buttons


